Support

Support

 

Browser Requirements

 

 browers

Update your browser

Most issue cases are related to outdated browsers.

Updating your browser will ensure compatibility with our technology.

We recommend Google Chrome which is always updated, and will ensure compatibility.

 

 

 

Mobile Users

iPhone and iPad

For Apple users, iOS 8 is required to use iVisit.

Click the button below for iOS upgrade instructions.

 

Android phones and tablets

All Android phones and tablets bought in the last 2 years should be compatible.

Click the button below to check if your device is WebGl compatible (required to use iVisit3D).